Author Topic: animation  (Read 2104 times)

Tomsy

  • Newbie
  • *
  • Posts: 30
animation
« on: January 22, 2016, 04:37:53 AM »
Hi. Don't know if this is a feature im not aware of or if it exists but is there an option to save animated objects made in tps? Ive built quite a few moving objects etc but no way of duplicating or saving the animations into new parks etc. As the keyframes take a very long time to do i feel this should be a must addition to tps. Just wanna know what ppl think cheerz!
please make some dark ride layouts!

davaze

  • Kickstarter Club Member
  • Sr. Member
  • ***
  • Posts: 399
Re: animation
« Reply #1 on: January 22, 2016, 06:38:32 AM »
Not sure but have you tried to just select your animated object(s) and export as custom scenery to one of your custom scenery folder. Make sure you have a 50x50px thumbnail picture ready to select when exporting as it does not work if you do not select any thumbnail pictures. After exporting to a custom folder re-start TPS so your custom object will be visible in the library you have put it and add it back into the scene. Not sure if it works because I have never made animated objects within TPS itself, I have only made flat rides with external 3D modeling software for TPS. Although these also have to be exported as custom scenery again after importing and animating it. Give it a try.

Tomsy

  • Newbie
  • *
  • Posts: 30
Re: animation
« Reply #2 on: January 22, 2016, 02:58:00 PM »
Cheers il try. The saving scenery seems to be hit and miss at the best of times. I sometimes end up with save scenery revering back to a block b4 i moulded it. Just wierd? Plus i cant seem to splice saved scenery either.
please make some dark ride layouts!

Xul

  • Full Member
  • ***
  • Posts: 239
Re: animation
« Reply #3 on: January 23, 2016, 12:11:57 AM »
I have always some problems with saving/loading custom objects. Sometimes it works, and sometimes the object looks totally wrong after loading it into my park. All parts are in a wrong position.

I never made animated objects so far, but the difficulties seem to have nothing to do with this. I don't think it's a bug in the custom scenary builder but a mistake I did myself. But I never found it out. As I said, some objects work fine, others don't...

davaze

  • Kickstarter Club Member
  • Sr. Member
  • ***
  • Posts: 399
Re: animation
« Reply #4 on: January 24, 2016, 10:36:42 PM »
Do you have that with objects created with TPS scenery builder or with objects imported which were created in 3DSMAX? I only have experience with objects created and imported from 33dsmax.

I have always some problems with saving/loading custom objects. Sometimes it works, and sometimes the object looks totally wrong after loading it into my park. All parts are in a wrong position.

I never made animated objects so far, but the difficulties seem to have nothing to do with this. I don't think it's a bug in the custom scenary builder but a mistake I did myself. But I never found it out. As I said, some objects work fine, others don't...

Tomsy

  • Newbie
  • *
  • Posts: 30
Re: animation
« Reply #5 on: January 25, 2016, 05:56:01 AM »
I have that problem in tps scenery builder. I haven't made any cs outside tps so its game errors i think. Its just random though with saved scenery. Very frustrating tbh
please make some dark ride layouts!

Xul

  • Full Member
  • ***
  • Posts: 239
Re: animation
« Reply #6 on: January 25, 2016, 11:32:12 AM »
for me it is the same. I created some simple objects (footbridges or gates) with the tps scenery builder because I want to be able to place them in all my parks. I saved the object and after loading it to ine of my existing parks the object is totally wrong composed.

But some of the other objects I created work fine, so it's not a mistake I made during the saving process. I don't know what I made wrong during composing the objects but I would never try to create more complex things with this editor because t seems to work not perfect to be honest...

Tomsy

  • Newbie
  • *
  • Posts: 30
Re: animation
« Reply #7 on: February 29, 2016, 02:33:52 AM »
has anybody looked into this yet? its been a while and I'm still getting these problems. Also when are we going to know when or if we can save keyframes with saved objects made in tps? Surely there must be a way of replicating animated objects so in every new park or saved animated scenery we don't have to go through the whole animation process every time.
please make some dark ride layouts!

abletudu

  • Administrator
  • Hero Member
  • *****
  • Posts: 2808
Re: animation
« Reply #8 on: February 29, 2016, 12:52:22 PM »
I am sure that this will be looked into as long as it is reported. Can you duplicate the problem and provide a step by step process as to how it happened, the more information you can provide will help find it.  A problem can not be fixed if it can't be duplicated. I know that Pantera appreciates the information.
A Proud Backer Of TPS! If you are having trouble using TPS refer to http://forum.themeparkstudio.com/index.php?board=19.0
To report problems or make suggestions go to https://themeparkstudio.mantishub.com/login_page.php?return=%2Fmy_view_page.php and register for an account.

Tomsy

  • Newbie
  • *
  • Posts: 30
Re: animation
« Reply #9 on: March 02, 2016, 05:16:57 AM »
There is no step by step process. It is purely random. Doesn't matter how i do create scenery it just decides to load it/save it different. Ive saved the same object a few times as different names and sometimes it loads up properly and others all shapes and sizes are loaded wrong. Step by step on custom in game building seems to have no bearing on it.
please make some dark ride layouts!

abletudu

  • Administrator
  • Hero Member
  • *****
  • Posts: 2808
Re: animation
« Reply #10 on: March 02, 2016, 07:01:02 AM »
Unfortunately random things are going to be harder to find. They have to be able to reproduce problems in order to get them fixed. Thanks for sharing this with the community and the developer.
A Proud Backer Of TPS! If you are having trouble using TPS refer to http://forum.themeparkstudio.com/index.php?board=19.0
To report problems or make suggestions go to https://themeparkstudio.mantishub.com/login_page.php?return=%2Fmy_view_page.php and register for an account.

Paul UK

  • Global Moderator
  • Full Member
  • *****
  • Posts: 206
  • Home Park - Chessington & Thorpe Park
Re: animation
« Reply #11 on: March 02, 2016, 09:57:32 AM »
The best thing I can suggest Tomsy, is use a screen recorder when you're playing and when it happens you'll have something to report on mantishub, and you can attach a link there to your video capture.

 

SMF 2.0.8 | SMF © 2014, Simple Machines

Page created in 0.241 seconds with 21 queries.

Analysis © 2010 by, Crip
Top